Fhir-bridge keeps failing

Hello everyone,

I am trying to use fhir-bridge for integrating Medplum and ehrbase, mvn clean install & mvn package worked fine. However, java -jar target/fhir-bridge-1.5.5.jar keep throwing an error (see as attached in the image)

What could I be doing wrong?

According to the exception details in the screenshot, a Spring bean factory method is parsing some fhir resource, but the parse itself is failing. This would lead to a cascading series of problems so Spring is doing the right thing and aborting the wiring of dependencies to their implementations.

If you’re in the mood for an adventure, you can go and check the requestValidatingInterceptor method’s implementation and see if you can isolate the parse that’s failing, to confirm this is the issue.

Remember that this is advice given by a random bloke on the Internet based on a screenshot though, so you may want to open and issue in Github before you consider my suggestion, EhrBase team is pretty good at responding to those :slight_smile:

Thanks for your response, the docker-container for fhir-bridge keeps failing upon starting it.

Hi @Muhammad_Abiodun_Sul,

I just checked out the latest version and tried building via mvn clean install. I can start without any issues using spring-boot:run or as you described:

So not super helpful but at least I can give the hint that the issue is not any faulty version of the bridge.

Thanks @birger.haarbrandt, mvn clean install works fine. However, running java -jar target/fhir-bridge-1.5.5.jar keeps throwing the error in the attached image.

Can you as well try running docker-compose -f docker-compose-full.yml up fhir-bridge. You’ll find that the image will stop with the error in the image I’ve attached herein

Also check out this image please

You uploaded an ValueSet as StructureDefinition in your FHIR profile folder.

The folder is only for profile SDs not for valuesets :wink: